CyberGL
search in CyberGL only
1 Visitor, 0 Member logged in
Signup Activation Login
Getting error when trying to import phpmembers.sql
Posted By: Chris, Posts: 1, Joined: 3 Sep 2007
error message:
#1067 - Invalid default value for 'member_id'
I'm using phpMyadmin 2.8.04 & MySql 4.1.11
 

 

1 Replies
#1 Replied by: Wibisono, at : 6 Sep 07, 16:09
Dear Chris,

What version do you use?
We assume that you use the latest version.

So please try use the SQL below:

CREATE TABLE `member_data` (
`member_id` mediumint(7) unsigned NOT NULL auto_increment,
`active` enum('disable','enable') NOT NULL default 'disable',
`firstname` char(24) NOT NULL default '',
`lastname` char(24) NOT NULL default '',
`email` char(32) NOT NULL default '',
`login` char(16) NOT NULL default '',
`PASSWORD` char(16) NOT NULL default '',
`occupation` tinyint(2) NOT NULL default '0',
`organization` char(32) NOT NULL default '',
`gender` enum('male','female') NOT NULL default 'male',
`birthdate` date NOT NULL default '0000-00-00',
`city` char(16) NOT NULL default '',
`zipcode` char(8) NOT NULL default '',
`state` char(8) NOT NULL default '',
`country` char(2) NOT NULL default '',
`website` char(32) NOT NULL default '',
`phone` char(16) NOT NULL default '',
`address` char(64) NOT NULL default '',
`createdate` date NOT NULL default '0000-00-00',
PRIMARY KEY (`member_id`),
UNIQUE KEY `login` (`login`),
KEY `login_2` (`login`)
) TYPE=MyISAM AUTO_INCREMENT=1 ;


Hopefully that can help

 

Login Form
Login:
Password:
Lost Password?